ZCash 1.0.8-1 mise à jour de sécurité importante

Le client Zcashd vient d’être mis à jour en version 1.0.8-1 suite à la découverte d’un bug pouvant provoquer le crash des nœuds du réseau.

Nous vous conseillons de mettre à jour rapidement vos installations afin de ne pas risquer d’être impactée par ce bug.

Source et mise à jour ZCash

Qui est en risque ? : L’ensemble des utilisateur de du client Zcashd de la version 1.0.4 à la version 1.0.8

Un travail a été fait avec les site principaux d’échange, et les porte-monnaies afin de mettre à jour leur infrastrucutre.

Qui n’est pas en risque ? : Les utilisateurs de la version 1.0.8-1

Comment savoir si une attaque s’est produite ? : Des détecteurs ont été mis en place sur différentes plateformes d’échange, fournisseurs de porte-monnaie et mineurs. Pour le moment aucune attaque n’a été détectée.

Informations techniques : A l’instar du Bitcoin, le Zcash assigne une priorité aux transactions afin de savoir celles qui devront être placées dans la liste mémoire. Dans la pratique le nombre reduit de transaction actuellement fait que ce mechanisme n’est pas utilisé, mais la fonction reste activée. Dans le version 1.0.4 de Zcash un changement a été apporté afin de modifié le calcul de cette prioritéet ainsi privilégier les transactions « shielded » (anonyme). Une erreur a été introduite, se qui ouvre la porte à une attaque pouvant provoquer une « segmentation fault » et donc le crash du client.

Des questions ou besoin d’aide pour la mise à jour n’hésitez pas à venir sur notre forum.

Article original : https://z.cash/blog/security-announcement-2017-04-13.html

Commentez l'article sur le Forum ZCash FR